Link style not working on one page

Hi,

I have defined the link style for the site in the extra CSS section of the theme. But on one of the pages the style is not applied.

The bold text in attached file should be the same color as all other links on the site. (the bold text "mer om Nellie" and "mer om Liz".



Comments

  • Hi,

    To do this, Go to Appearance >> Customize >> Additional CSS and add the given below custom CSS code:

    a:hover {
        color: #24736a !important;
    }

    Note: Change the color value as per your need. 

    I hope it will work for you!

    Thanks
    Dev
  • I already have this customized CSS specified.

    .entry-content a {
        color: #24736a;
    }

    .entry-content a:hover {
        color: #43b5a7;
    }
  • Hi,

    This class does not exist on this page. So, it does not work for this particular page.

    If you want to apply link style at this page, then please add the given below custom CSS code:

    a {
        color: #24736a !important;
    }

    a:hover {
        color: #43b5a7 !important;
    }  

    I hope it will work for you!

    Thanks
    Dev
  • Now I am confused. How come it works on all other pages?
  • Also, then the same thing happens with the button (as it did on the other pages), that text should not be the same as the links in the text. I already have this extra CSS.

    a.wp-block-button__link.has-background {
        color: #ffffff;
    }
  • Hi,

    Sorry for my mistake, please replace the above CSS code by the given following  CSS: 

    .page-template-template p a {
        color: #24736a !important;
    }
    .page-template-template p a:hover {
        color: #43b5a7 !important;
    }

    I hope it will work for you!

    Thanks
    Dev
Sign In or Register to comment.