Adding fonts

I'd like to change to another font. Looked at the drop-downs in the "Typography Settings" and was happy to discover the many options. However when I try to change they all look the same.
Grateful for support,


  • Hi, @ludde19

    Maybe you have not enable the custom typography option. It needs to be enabled to see the effects. Screenshot

    Let me know if any confusion!

  • Thanks for your feedback.
    Yes the boxed was ticked. I have tried many of the fonts but I from what I can see, only two variants of the font
    1) The default (Dosis)
    2) Something close to San Serif

    Great if you could come up with some suggestions.

  • I'm having the same problem too. I'm on version 2.8.1 that I just installed and none of my changes to the typography will work even after enabling custom typography.
  • I take back my last comment; I got it to work, but it turns out that the sections don't make sense. That is, what I thought was a Section Title wasn't the title areas I expected. When updating the General Description, it seemed to affect most of the fonts - that's not my preference, but at least it's working.
  • @statstuff Please never post comment to the other's open thread, it creates complexity to handle the support. However, its working fine at our end, but you can try to check after disabling the plugins one by one, with also cleared browser's cache memory. Still If it does not work, then you can please share us your admin details on my email address: So that I can debug this issue if there is any thing.

  • Hi, @ludde19

    Please let us know did your problem solved or not?

Sign In or Register to comment.