"Updating failed. The response is not a valid JSON response". with [spicepress_team] shortcode

Dear Developers,

I want to have the teams section on a different separate site and tried to followed you shortcode guide https://helpdoc.spicethemes.com/spicepress/how-to-use-homepage-sections-on-another-page-using-shortcode/

This is not working for me. I get Errors “This is not a valid JSON response” as soon as I use the shortcode [spicepress_team]. It still works on the “business template” start page

In this forum I found a related post, regarding the same problems with [spicepress_testimonial] (at least I think the problem is the same). It says it is a problem with the Gutenberg Editor starting with Wordpress 5.0

https://support.spicethemes.com/index.php?p=/discussion/comment/1736/#Comment_1736

is there a similar fix for the spicepress_team shortcode?

I also tried the "Classic Editor” 1.5 plugin to test it with the “old” editor but it also didn’t work.

Thank you, Peter

Comments


  • To do this, follow the below instructions:

    1) Install the Code Snippets plugin.
    2) Add New code snippets and paste this code
    3) Save and activate it.

    After this, try short code like: 
    [spicepress_service1]
    [spicepress_portfolio1]
    [spicepress_testimonial1]
     
    Let me know did it work!

    Thanks
    Dev
  • Thank you for your quick answer.
    Both [spicepress_service1] and [spicepress_portfolio1] are working well but the [spicepress_team1] is not displayed correctly. I attached a screenshot of how it looks on the welcome-page and how it looks on a different page. However, the “Updating failed” message disappeared.
    Best Regards, Peter

    appearance_full_width_page_with_shortcode.png
    1668 x 862 - 107K
    appearance_on_business_template_page.png
    1880 x 810 - 395K
  • Hi,

    Please check again [spicepress_team1] shortcode for showing team member . Because It's working fine at our end. Otherwise share your site URL so that we can take a closer look and assist you better. 

    Thanks
    Dev
  • Hi,
    I again checked all the steps with the snippet and even reuploaded the whole theme, but the [spicepress_team1] shortcode does not work with my team.
    However, when I insert $team_options = ‘’; in line 610 of you code your team is displayed correctly using the [spicepress_team1]. Please try to create your “own” different team and check if you have the same error-behaviour. (The site-url is david-trallori.at). Please see the screenshots.
    Best Peter.

    add_code_to_snippet.png
    589 x 383 - 24K
    your_team_looks_perfect.png
    1308 x 640 - 361K
  • Hi,

    We re-checked at our end & it's working fine. We can't debug what's wrong at your end you can please send us your admin details at my email id(devendrakdosaya@gmail.com), so can we sort out the what's wrong.

    Thanks
    Dev
  • Hi,

    Please check your site, your problem is resolved.
    If problem solve then let me know for confirmation.

    Thanks
    Dev
  • Hi,

    Thank you for your changes. Now it works and looks very good. Can you tell me how you fixed it?

    Best Peter.
  • Glad to help you!
    I fixed some syntax issue in team shortcode.
    If you like our Theme & Support, rate us HERE.

    Thanks
This discussion has been closed.